It is currently Thu Dec 03, 2020 3:04 am

All times are UTC + 5:30 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Dec 01, 2017 3:31 pm 
Offline

Joined: Mon Mar 14, 2016 12:36 pm
Posts: 46
Which Version of PHP Used for Magento?


Top
 Profile  
 
PostPosted: Fri Dec 01, 2017 4:06 pm 
Offline

Joined: Tue Jul 12, 2016 12:22 pm
Posts: 30
The new version of the Magento e-commerce platform is the version v.2. The platform supports Nginx by default, however, there are some requirements and it must be optimized for better and smoother performance. PHP7 is the best suited version to run and accelerated the Magento software.

PHP7 is the latest and newly launched stable version after PHP 5.6. PHP6 was released in its beta version but never developed further. PHP7 can steer the online sites with numerous improvements. Almost all the popular CMS platforms like WordPress, Joomla, Drupal depend on the new PHP system.

Magento development will be a lot easier and simpler in addition to be faster with PHP7. It is estimated to double up the speed so far as performance is concerned. It is very effective and highly safe and secure from uninvited bugs and security breaches. However, PHP7 may not work smoothly with the earlier versions of Magento since the compatibility levels differ. For the earlier versions, i.e. Magento1.6 and 1.7, you require PHP versions of 5.2 and above.

The other Magento2 system requirements include

Composer – the PHP manager

Varnish- the HTTP accelerator

Redis- the key-value cache

MySQL- the important component of LAMP configuration. You need MySQL v5.6 or more.

PHPUnit and XDebug

PHP extensions like PDO/MySQL, mbstring, Mcrypt, mhash, SimpleXML, openssl, intl, soap, and more.


Top
 Profile  
 
PostPosted: Mon Dec 16, 2019 11:30 am 
Offline

Joined: Mon Dec 16, 2019 11:21 am
Posts: 3
Hi,
Magento have released its v.2 version. Same PHP has released its v.7. As these both the latest version they are the best suit and compatible. I would Recommend that you use PHP v.7 for your Magento because with v.7 the Magento Development would be fast and simple.


Top
 Profile  
 
PostPosted: Mon Dec 23, 2019 12:27 pm 
Offline

Joined: Mon Dec 16, 2019 11:21 am
Posts: 3
For Magento 2.3
Supported PHP versions:
~7.1.3
~7.2.0
~7.3.0
also Magento 2.3.1 is certified and tested on PHP 7.2.11. Magento 2.3.3 adds support for PHP 7.3.


Top
 Profile  
 
PostPosted: Mon Feb 03, 2020 4:39 pm 
Offline

Joined: Mon Feb 03, 2020 4:25 pm
Posts: 4
Technologies Magento can use
Version 5.0 is highly recommended. Magento 2.3 uses Elasticsearch PHP client version 6.1.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 5:30 hours


Who is online

Registered users: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron